SingleStore DB

SingleStore DB Studio Upgrade

Important

SingleStore DB Studio is designed to work with MemSQL 6.5 or later and is only supported on Chrome and Firefox browsers at this time.

Upgrading SingleStore DB Studio can be done through the package manager on the machine, instance, or container where SingleStore DB Studio is installed.

To update the singlestoredb-studio package with YUM, run the following:

sudo yum update singlestoredb-studio

If you’re running singlestoredb-studio as a systemd service, it will be automatically restarted after you install the new version. However, if you’re running singlestoredb-studio directly, you have to restart the server after installing the new version of the package.

  1. To update the singlestoredb-studio package with APT, update the package lists for packages that need upgrading, as well as new packages that have just come to the repositories.

    sudo apt update
  2. Update the singlestoredb-studio package.

    sudo apt install singlestoredb-studio

If you’re running singlestoredb-studio as a systemd service, it will be automatically restarted after you install the new version. However, if you’re running singlestoredb-studio directly, you have to restart the server after installing the new version of the package.