SingleStore DB

Assumptions and Prerequisites

This document assumes that you are familiar with Kerberos concepts and know how to administer a realm. Depending on your Kerberos environment, some of the guidance in this document may require changes to adhere to your realm’s configuration.

Before you can start using Kerberos authentication in SingleStore DB, ensure that your system meets the following prerequisites:

  • MemSQL Version: 5.7.4 or newer

  • MariaDB Client Version: Currently, no official MySQL clients support Kerberos/GSSAPI authentication; however, specific MariaDB clients do support Kerberos, and they are compatible with SingleStore DB. See [Client Driver Downloads]({{< relref /client-downloads.md >}}) for the ODBC, JDBC, and C++ clients that you can use to authenticate SingleStore DB users.

  • MariaDB GSSAPI Authentication Plugin: In addition to a MariaDB client or connector, you must also have the GSSAPI Authentication Plugin available on the connecting machine. The plugin is then referenced in the connection string when connecting with a client or connector. The GSSAPI plugin is packaged with the MariaDB database software itself, so you must download one of the stable or prerelease versions here. Once downloaded, the plugin is located in a path such as mariadb-<version>/plugin for Unix/Linux, or mariadb-<version>\lib\plugin for Windows. For more information about the plugin, see the MariaDB documentation.