Migrate between SingleStore Spark Connector Versions

Note

The SingleStore Spark Connector versions 2.0 and 3.0 are no longer supported.

The following sections describe the differences in configuration and functionality between the SingleStore Spark Connector versions.

Version 3.2 > 4.0

  • Update the JDBC driver to use the SingleStore JDBC driver instead of MariaDB JDBC driver. See The SingleStore JDBC Driver for more information.